本文图片失效,有空再补上吧,可以先看视频讲解,很详细。

地址:http://www.bilibili.com/video/av16168895/?zw

我们学的是协议

协议顾名思义就是经过国际组织或者有关部门统一协商并且明文规定的,每个厂商都应该遵守的标准。

我们学的大部分协议都是公有的。例如:ospf, bgp, isis, stp, mpls,组播等。

还有一些协议是厂商根据某一标准制自己制定出来的。例如:思科的路由协议:EIGRP 华三的智能弹性架构:IRF; 华为的HRP。

各个厂商的模拟器

华为模拟器:ENSP

下载地址:

http://support.huawei.com/enterprise/zh/tool/ensp-TL1000000015

华三模拟器:H3C云实验室

下载地址:

http://www.h3c.com/cn/Service/Software_Download/Other_Product/

思科模拟器:Gns3

下载地址:

http://pan.baidu.com/s/1slEtkQD

对接实验

gns3模拟器使用基础教程:

http://www.tatait.com/html/2013/09/04/201309040344280781251285.html

思科简明配置手册:

http://www.net130.com/tutorial/jmshc/001.htm

ospf配置命令:

win7添加虚拟网卡(用于后面各个模拟器的桥接)

http://jingyan.baidu.com/article/b87fe19eb3f0f05219356858.html

添加完成可以看到已经添加了一个本地连接回环网卡

邮件属性打开IPv4协议,将ip地址设为自动获取(很重要!!!)

接下来进入正题:各个模拟器实现和这个本机虚拟网卡的桥接,进而实现各个模拟器之间的对接!

  • ENSP模拟器实现桥接:

在是设备中选择cloud,拖放到右边:

配置cloud:

先按照下面的顺序添加一个UDP端口

再添加一个刚刚新建的本地连接3虚拟网卡

接下来在下面增加双向通道就ok了。

此时我们就将ENSP模拟器的设备和本地网卡桥接到了一起,此时本机就可以和ensp上的设备通信了。

  • GNS3模拟器实现桥接:

GNS3模拟器的桥接和ensp十分相似

右击cloud,设置:

选择本地连接3

添加,然后点击apply。

此时GNS3中的桥接已经完成

  • H3C模拟器实现桥接:

在左侧选择HOST

右击连线选择回环网卡

此时H3C的模拟器桥接已经完成

在华为和H3C模拟器上配置OSPF 协议,实现互通

逻辑上就相当于下图:

配置如下:

华为路由器:

#
sysname R1
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password cipher OOCM4m($F4ajUn1vMEIBNUw#
 local-user admin service-type http
#
firewall zone Local
 priority 16
#
interface Ethernet0/0/0
 ip address 192.168.1.1 255.255.255.0
#
interface Ethernet0/0/1
#
interface Serial0/0/0
 link-protocol ppp
#
interface Serial0/0/1
 link-protocol ppp
#
interface Serial0/0/2
 link-protocol ppp
#
interface Serial0/0/3
 link-protocol ppp
#
interface GigabitEthernet0/0/0
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
#
wlan
#
interface NULL0
#
interface Logic-Channel0
#
interface LoopBack0
 ip address 1.1.1.1 255.255.255.255
#
ospf 1
 area 0.0.0.0
  network 192.168.1.1 0.0.0.0
  network 1.1.1.1 0.0.0.0
#
user-interface con 0
user-interface vty 0 4
user-interface vty 16 20
#
return
`</pre>

H3C路由器配置如下:

<pre>`#
 version 7.1.075, Alpha 7571
#
 sysname H3C
#
ospf 1
 area 0.0.0.0
  network 192.168.1.2 0.0.0.0
  network 2.2.2.2 0.0.0.0
#
 system-working-mode standard
 xbar load-single
 password-recovery enable
 lpu-type f-series
#
vlan 1
#
interface Serial1/0
#
interface Serial2/0
#
interface Serial3/0
#
interface Serial4/0
#
interface NULL0
#
interface LoopBack0
 ip address 2.2.2.2 255.255.255.255
#
interface GigabitEthernet0/0
 port link-mode route
 combo enable copper
 ip address 192.168.1.2 255.255.255.0
#
interface GigabitEthernet0/1
 port link-mode route
 combo enable copper
#
interface GigabitEthernet0/2
 port link-mode route
 combo enable copper
#
interface GigabitEthernet5/0
 port link-mode route
 combo enable copper
#
interface GigabitEthernet5/1
 port link-mode route
 combo enable copper
#
interface GigabitEthernet6/0
 port link-mode route
 combo enable copper
#
interface GigabitEthernet6/1
 port link-mode route
 combo enable copper
#
 scheduler logfile size 16
#
line class aux
 user-role network-operator
#
line class console
 user-role network-admin
#
line class tty
 user-role network-operator
#
line class vty
 user-role network-operator
#
line aux 0
 user-role network-operator
#
line con 0
 user-role network-admin
#
line vty 0 63
 user-role network-operator
#
domain system
#
 domain default enable system
#
role name level-0
 description Predefined level-0 role
#
role name level-1
 description Predefined level-1 role
#
role name level-2
 description Predefined level-2 role
#
role name level-3
 description Predefined level-3 role
#
role name level-4
 description Predefined level-4 role
#
role name level-5
 description Predefined level-5 role
#
role name level-6
 description Predefined level-6 role
#
role name level-7
 description Predefined level-7 role
#
role name level-8
 description Predefined level-8 role
#
role name level-9
 description Predefined level-9 role
#
role name level-10
 description Predefined level-10 role
#
role name level-11
 description Predefined level-11 role
#
role name level-12
 description Predefined level-12 role
#
role name level-13
 description Predefined level-13 role
#
role name level-14
 description Predefined level-14 role
#
user-group system
#
return

查看ospf邻居状态:

可以看到ospf邻居可以FULL

查看路由表:

路由学习正常!